Tuesday, September 29, 2015

CollabNet Subversion Edge 5.1.0, Trac and mod_wsgi on Windows

As I've blogged before, I think CollabNet Subversion Edge to be quite handy. Now there's a new version (5.1.0) out that addresses several issues. I found that compiling mod_wsgi isn't necessary anymore. But they still ship a version of mod_wsgi that doesn't work.....

Luckily mod_wsgi binaries for various Python versions can be downloaded here. The key is to know which Python version and which Visual C version to use.
For CollabNet Subversion Edge Python 2.7 and Visual C 9 work. As I'm running it on a 64-bit platform, I chose this file from the archive:
The top folder is a bit of a misnomer, because it actually contains files compiled with VC9 and VC10. But hey, it's free so who are we to complain?

Stop Apache and replace the mod_wsgi in the csvn/lib/modules folder. And you're ready to enjoy speedy python.

No comments: